Net::SSH::Perl

Friday, January 15, 2010 , Posted by Johnny Fuery at 9:43 AM

Originally Published 2003-10-06 01:46:26

...is required for Net::SFTP and has dependencies on everything known to man. Looks like net-ssh-perl-1.23 requires a later version than 5.6.1. Joy.



Here's my list of dependencies:



Package Dependencies

dev-perl/Math-GMP dev-perl/string-crc32 dev-perl/math-pari dev-perl/Digest-MD5 dev-perl/Digest-SHA1 dev-perl/Digest-HMAC dev-perl/crypt-dh dev-perl/crypt-dsa dev-perl/math-pari dev-perl/MIME-Base64 dev-perl/convert-pem dev-perl/Crypt-Blowfish dev-perl/Crypt-DES dev-perl/crypt-idea dev-perl/Crypt-OpenSSL-RSA dev-perl/crypt-rsa dev-perl/digest-bubblebabble >=dev-lang/perl-5.8.0-r12



Run-Time Dependencies

dev-perl/Math-GMP dev-perl/string-crc32 dev-perl/math-pari dev-perl/Digest-MD5 dev-perl/Digest-SHA1 dev-perl/Digest-HMAC dev-perl/crypt-dh dev-perl/crypt-dsa dev-perl/math-pari dev-perl/MIME-Base64 dev-perl/convert-pem dev-perl/Crypt-Blowfish dev-perl/Crypt-DES dev-perl/crypt-idea dev-perl/Crypt-OpenSSL-RSA dev-perl/crypt-rsa dev-perl/digest-bubblebabble



Dear god have mercy. And, of course, I have 5.6.1 on avanthost.com. Fuck me. Upgrading perl with all of those modules on a production web server?



I'm so screwed. Fuck!

Currently have 0 comments:

Leave a Reply

Post a Comment